2018

06/26

09:12

来源:
CNVD漏洞平台

微信

新浪

关于WebLogic Server WLS核心组件存在反序列化漏洞的风险提示

  2018年4月18日,国家信息安全漏洞共享平台(CNVD)收录了WebLogic Server WLS核心组件反序列化漏洞(CNVD-2018-07811,对应CVE-2018-2628)。攻击者利用该漏洞,可在未授权的情况下远程执行代码。漏洞验证代码已被公开,近期被不法分子利用进行大规模攻击的可能性较大,厂商已发布补丁进行修复。

  一、漏洞情况分析

  WebLogicServer是美国甲骨文(Oracle)公司开发的一款适用于云环境和传统环境的应用服务中间件,它提供了一个现代轻型开发平台,支持应用从开发到生产的整个生命周期管理,并简化了应用的部署和管理。在WebLogic Server 的 RMI(远程方法调用)通信中,T3协议(丰富套接字)用来在 WebLogic Server 和其他 Java 程序(包括客户端及其他 WebLogic Server 实例)间传输数据,该协议在开放WebLogic控制台端口的应用上默认开启。

  2018年4月18日凌晨,Oracle官方发布了4月份关键补丁更新CPU(CriticalPatch Update),其中包含该Weblogic反序列化高危漏洞。利用该漏洞,攻击者可以在未经授权的情况下,远程发送攻击数据,通过T3协议在WebLogic Server中执行反序列化操作,反序列过程中会远程加载RMI registry,加载回来的registry又会被反序列化执行,最终实现了远程代码的执行。

  CNVD对该漏洞的综合评级为“高危”。

  二、漏洞影响范围

  根据官方公告情况,该漏洞的影响版本如下:

  WebLogic10.3.6.0

  WebLogic12.1.3.0

  WebLogic12.2.1.2

  WebLogic12.2.1.3

  CNVD秘书处组织对WebLogic服务在全球范围内的分布情况进行了统计,结果显示该服务的全球规模约为6.9万,其中我国境内的用户量约为1.2万。随机抽样检测结果显示,大约为6%的WebLogic服务受此漏洞影响。

  三、漏洞处置建议

  1、临时修复建议:通过设置weblogic.security.net.ConnectionFilterImpl默认连接筛选器,对T3/T3s协议的访问权限进行配置,阻断漏洞利用途径。

  2、美国甲骨文公司已发布了修复补丁,建议及时更新至最新版本:

  http://www.oracle.com/technetwork/security-advisory/cpuapr2018-3678067.html。

  附:参考链接:

  http://www.cnvd.org.cn/flaw/show/CNVD-2018-07811

  http://www.oracle.com/technetwork/security-advisory/cpuapr2018-3678067.html

  http://toutiao.secjia.com/cve-2018-2628

  天津市网信办提示广大企业和互联网用户采取有效措施进行防控:及时开展自查,安装修复补丁,避免出现网络安全事故。

关于WebLogic Server WLS核心组件存在反序列化漏洞的风险提示

2018 09:12来源:CNVD漏洞平台

  2018年4月18日,国家信息安全漏洞共享平台(CNVD)收录了WebLogic Server WLS核心组件反序列化漏洞(CNVD-2018-07811,对应CVE-2018-2628)。攻击者利用该漏洞,可在未授权的情况下远程执行代码。漏洞验证代码已被公开,近期被不法分子利用进行大规模攻击的可能性较大,厂商已发布补丁进行修复。

  一、漏洞情况分析

  WebLogicServer是美国甲骨文(Oracle)公司开发的一款适用于云环境和传统环境的应用服务中间件,它提供了一个现代轻型开发平台,支持应用从开发到生产的整个生命周期管理,并简化了应用的部署和管理。在WebLogic Server 的 RMI(远程方法调用)通信中,T3协议(丰富套接字)用来在 WebLogic Server 和其他 Java 程序(包括客户端及其他 WebLogic Server 实例)间传输数据,该协议在开放WebLogic控制台端口的应用上默认开启。

  2018年4月18日凌晨,Oracle官方发布了4月份关键补丁更新CPU(CriticalPatch Update),其中包含该Weblogic反序列化高危漏洞。利用该漏洞,攻击者可以在未经授权的情况下,远程发送攻击数据,通过T3协议在WebLogic Server中执行反序列化操作,反序列过程中会远程加载RMI registry,加载回来的registry又会被反序列化执行,最终实现了远程代码的执行。

  CNVD对该漏洞的综合评级为“高危”。

  二、漏洞影响范围

  根据官方公告情况,该漏洞的影响版本如下:

  WebLogic10.3.6.0

  WebLogic12.1.3.0

  WebLogic12.2.1.2

  WebLogic12.2.1.3

  CNVD秘书处组织对WebLogic服务在全球范围内的分布情况进行了统计,结果显示该服务的全球规模约为6.9万,其中我国境内的用户量约为1.2万。随机抽样检测结果显示,大约为6%的WebLogic服务受此漏洞影响。

  三、漏洞处置建议

  1、临时修复建议:通过设置weblogic.security.net.ConnectionFilterImpl默认连接筛选器,对T3/T3s协议的访问权限进行配置,阻断漏洞利用途径。

  2、美国甲骨文公司已发布了修复补丁,建议及时更新至最新版本:

  http://www.oracle.com/technetwork/security-advisory/cpuapr2018-3678067.html。

  附:参考链接:

  http://www.cnvd.org.cn/flaw/show/CNVD-2018-07811

  http://www.oracle.com/technetwork/security-advisory/cpuapr2018-3678067.html

  http://toutiao.secjia.com/cve-2018-2628

  天津市网信办提示广大企业和互联网用户采取有效措施进行防控:及时开展自查,安装修复补丁,避免出现网络安全事故。

为你推荐

国家计算机病毒应急处理中心监测发现十

近日在净网行动中,国家计算机病毒应急处理中心通过互联网监测发现,10款违法有害移动应用存在于移动应用发布平台中,其主要危害涉及隐私窃取、恶意传播、资费消耗、系统破坏……

钓鱼邮件攻击防范指南

钓鱼邮件是指黑客伪装成同事、合作伙伴、朋友、家人等用户信任的人,通过发送电子邮件的方式,诱使用户回复邮件、点击嵌入邮件正文的恶意链接或者打开邮件附件以植入木马……

关于华硕路由器存在跨站脚本攻击漏洞的

近日,国家信息安全漏洞共享平台CNVD收录了台湾华硕电脑股份有限公司开发的型号为RT-AC58U的路由器存在反射型跨站脚本攻击漏洞(CNVD编号:CNVD-2018-21251)。